首页 -> 安全研究

安全研究

安全漏洞
libxls缓冲区溢出漏洞(CVE-2023-38851)

发布日期:2023-08-15
更新日期:2023-12-04

受影响系统:
libxls libxls 1.6.2
描述:
CVE(CAN) ID: CVE-2023-38851

libxls是Libxls个人开发者的一个基于C的用于从OLT格式的xls文件读取数据的代码库。
libxls 1.6.2版本存在缓冲区溢出漏洞,远程攻击者可利用该漏洞通过xls.c:1018中的xls_parseWorkBook函数中特制的XLS文件执行任意代码并导致拒绝服务。

<**>

建议:
厂商补丁:

libxls
------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

https://github.com/libxls/libxls/issues/124

浏览次数:424
严重程度:0(网友投票)
本安全漏洞由绿盟科技翻译整理,版权所有,未经许可,不得转载
绿盟科技给您安全的保障