首页 -> 安全研究

安全研究

安全漏洞
Jenkins JaCoCo Plugin跨站脚本漏洞(CVE-2023-28669)

发布日期:2023-03-21
更新日期:2023-03-28

受影响系统:
Jenkins Jenkins JaCoCo Plugin <= 3.3.2
描述:
CVE(CAN) ID: CVE-2023-28669

Jenkins和Jenkins Plugin都是Jenkins开源的产品,Jenkins是一个应用软件,一个开源自动化服务器Jenkins提供了数百个插件来支持构建,部署和自动化任何项目,Jenkins Plugin是一个应用软件。
Jenkins JaCoCo Plugin 3.3.2及之前版本存在跨站脚本漏洞,该漏洞源于程序未对UI中显示的类和方法名称进行正确转义,攻击者可利用该漏洞控制“Record JaCoCo coverage report”构建后操作的输入文件。

<*来源:Kevin Guerroudj (CloudBees, Inc.)
  
  链接:https://www.jenkins.io/security/advisory/2023-03-21/
*>

建议:
厂商补丁:

Jenkins
-------
Jenkins已经为此发布了一个安全公告()以及相应补丁:
:Stored XSS vulnerability in JaCoCo Plugin
链接:https://www.jenkins.io/security/advisory/2023-03-21/

浏览次数:415
严重程度:0(网友投票)
本安全漏洞由绿盟科技翻译整理,版权所有,未经许可,不得转载
绿盟科技给您安全的保障