首页 -> 安全研究

安全研究

安全漏洞
ua-parser-js拒绝服务漏洞(CVE-2022-25927)

发布日期:2023-01-26
更新日期:2023-03-23

受影响系统:
ua-parser-js ua-parser-js >= 0.8.1
ua-parser-js ua-parser-js >= 0.7.30
ua-parser-js ua-parser-js < 1.0.33
ua-parser-js ua-parser-js < 0.7.33
描述:
CVE(CAN) ID: CVE-2022-25927

ua-parser-js是基于JavaScript的User-Agent字符串解析器。可以在浏览器(客户端)或node.js(服务器端)环境中使用。
ua-parser-js 0.7.30至0.7.33之前版本和0.8.1至1.0.33之前版本存在拒绝服务漏洞。攻击者可利用该漏洞通过trim()函数导致拒绝服务。

<**>

建议:
厂商补丁:

ua-parser-js
------------
目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:

https://github.com/faisalman/ua-parser-js/commit/a6140a17dd0300a35cfc9cff999545f267889411

浏览次数:578
严重程度:0(网友投票)
本安全漏洞由绿盟科技翻译整理,版权所有,未经许可,不得转载
绿盟科技给您安全的保障