首页 -> 安全研究

安全研究

安全漏洞
Cyrus SASL SASL_PATH环境变量权限提升漏洞

发布日期:2004-10-07
更新日期:2004-10-09

受影响系统:
Carnegie Mellon University Cyrus-SASL 2.1.18
不受影响系统:
Carnegie Mellon University Cyrus-SASL 2.1.19
描述:
CVE(CAN) ID: CVE-2004-0884

Cyrus SASL提供多个用于安全认证的开放源代码实现。

Cyrus SASL对SASL_PATH环境变量处理不正确,本地攻击者可以利用这个漏洞进行提升特权攻击。

攻击者可以利用SASL_PATH环境变量,使特权应用程序从用户指定的任意目录中装载任意库文件,可导致恶意程序以高特权运行。

<*来源:Cyrus
  
  链接:http://www.securitytracker.com/alerts/2004/Oct/1011568.html
*>

建议:
厂商补丁:

Carnegie Mellon University
--------------------------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

https://bugzilla.andrew.cmu.edu/cgi-bin/cvsweb.cgi/src/sasl/lib/common.c.diff?r1=1.103&r2=1.104

Cyrus SASL 2.1.19已经修复此漏洞。

浏览次数:2350
严重程度:0(网友投票)
本安全漏洞由绿盟科技翻译整理,版权所有,未经许可,不得转载
绿盟科技给您安全的保障