首页 -> 安全研究

安全研究

安全漏洞
CODESYS V3 远程堆溢出漏洞(CVE-2020-10245)

发布日期:2020-03-30
更新日期:2020-04-01

受影响系统:
codesys CODESYS V3 web server < 3.5.15.40
描述:
CVE(CAN) ID: CVE-2020-10245

CODESYS V3 web server是一款使用在CODESYS产品中的Web服务器。

CODESYS V3 web server 3.5.15.40之前版本,未正确验证服务器URL端点/WebVisuV3收到的用户输入,在CmpWebServerHandlerV3.dll中存在缓冲区溢出漏洞。攻击者可利用该漏洞导致缓冲区溢出,造成web服务器崩溃或可被用于远程执行代码。

<*来源:vendor
  
  链接:https://zh-cn.tenable.com/security/research/tra-2020-16?tns_redirect=true
*>

测试方法:

警 告

以下程序(方法)可能带有攻击性,仅供安全研究与教学之用。使用者风险自负!

vendor ()提供了如下测试方法:
https://github.com/tenable/poc/blob/master/codesys/codesys_v3_webserver_int32_overflow_tra_2020_16.py

建议:
厂商补丁:

codesys
-------
目前厂商已经发布了升级补丁3.5.15.40版本修复了这个安全问题,请到厂商的主页下载:

https://customers.codesys.com/index.php?eID=dumpFile&t=f&f=13078&token=de344ca65252463cc581ef144e0c53bd97b8f211&download=

浏览次数:65
严重程度:0(网友投票)
本安全漏洞由绿盟科技翻译整理,版权所有,未经许可,不得转载
绿盟科技给您安全的保障