首页 -> 安全研究

安全研究

安全漏洞
WordPress photo-gallery插件跨站脚本执行漏洞(CVE-2019-16117)

发布日期:2019-09-06
更新日期:2019-09-10

受影响系统:
WordPress photo-gallery < 1.5.35
描述:
CVE(CAN) ID: CVE-2019-16117

WordPress是一套使用PHP语言开发的博客平台。photo-gallery是使用在其中的一个图片库插件。

WordPress photo-gallery插件1.5.35之前版本,在实现中存在跨站脚本漏洞。该漏洞源于admin/models/Galleries.php缺少对客户端数据的正确验证。攻击者可利用该漏洞执行客户端代码。

<*来源:vendor
  *>

建议:
厂商补丁:

WordPress
---------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

https://wordpress.org/plugins/photo-gallery/#developers

https://plugins.trac.wordpress.org/changeset/2150912/photo-gallery/trunk/admin/models/Galleries.php?old=2135029&old_path=photo-gallery%2Ftrunk%2Fadmin%2Fmodels%2FGalleries.php

浏览次数:1386
严重程度:0(网友投票)
本安全漏洞由绿盟科技翻译整理,版权所有,未经许可,不得转载
绿盟科技给您安全的保障