首页 -> 安全研究

安全研究

安全漏洞
RubyGems 'paranoid2'远程代码执行漏洞(CVE-2019-13589)

发布日期:2019-08-01
更新日期:2019-08-01

受影响系统:
RubyGems paranoid2 1.1.6
描述:
BUGTRAQ  ID: 109281
CVE(CAN) ID: CVE-2019-13589

RubyGems 'paranoid2'是一款基于Ruby的paranoid模型。
RubyGems.org提供的分发Ruby程序的paranoid2 gem 1.1.6存在第三方插入的代码执行后门。攻击者可利用该漏洞在受影响系统的上下文中执行任意代码。

<*来源:lingfennan
  *>

建议:
厂商补丁:

RubyGems
--------
目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:

http://rubygems.org/gems/rubyzip

浏览次数:1366
严重程度:0(网友投票)
本安全漏洞由绿盟科技翻译整理,版权所有,未经许可,不得转载
绿盟科技给您安全的保障