首页 -> 安全研究

安全研究

安全漏洞
WordPress远程代码执行漏洞(CVE-2019-8942)

发布日期:2019-07-15
更新日期:2019-07-15

受影响系统:
WordPress WordPress 5.0
WordPress WordPress 4.9.9
不受影响系统:
WordPress WordPress 5.0.1
描述:
BUGTRAQ  ID: 107088
CVE(CAN) ID: CVE-2019-8942

WordPress是WordPress基金会的一套使用PHP语言开发的博客平台。该平台支持在PHP和MySQL的服务器上架设个人博客网站。
WordPress 4.9.9之前版本和5.0.1之前的5.x版本中存在远程代码执行漏洞,该漏洞源于an _wp_attached_file Post Meta 条目可更改为任意字符串,如以.jpg?file.php substring结尾的子字符串。具有作者权限的攻击者可利用该漏洞通过上传Exif元数据中包含PHP代码的特制图片来执行任意代码。

<*来源:Simon Scannell
  *>

建议:
厂商补丁:

WordPress
---------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

http://wordpress.org/

浏览次数:1103
严重程度:0(网友投票)
本安全漏洞由绿盟科技翻译整理,版权所有,未经许可,不得转载
绿盟科技给您安全的保障