首页 -> 安全研究

安全研究

安全漏洞
Moodle任意PHP代码执行漏洞(CVE-2019-11631)

发布日期:2019-04-28
更新日期:2019-05-05

受影响系统:
Moodle Moodle 3.6.3
描述:
BUGTRAQ  ID: 108119
CVE(CAN) ID: CVE-2019-11631

Moodle是澳大利亚马丁-多基马(Martin Dougiamas)博士开发的一套免费、开源的电子学习软件平台,也称课程管理系统、学习管理系统或虚拟学习环境。
Moodle 3.6.3允许远程认证管理员通过ZIP文件执行任意PHP代码,该ZIP文件位置为repository/repository_ajax.php?action=upload and admin/tool/installaddon/index.php,含有一个theme_*.php文件。

<*来源:AkkuS
  *>

建议:
厂商补丁:

Moodle
------
目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:

http://moodle.org/

浏览次数:1455
严重程度:0(网友投票)
本安全漏洞由绿盟科技翻译整理,版权所有,未经许可,不得转载
绿盟科技给您安全的保障