首页 -> 安全研究

安全研究

安全漏洞
Samba 目录遍历漏洞(CVE-2019-3880)

发布日期:2019-04-08
更新日期:2019-04-08

受影响系统:
RedHat Samba < 4.9.6
RedHat Samba < 4.8.11
RedHat Samba < 4.10.2
RedHat Samba
不受影响系统:
RedHat Samba 4.9.6
RedHat Samba 4.8.11
RedHat Samba 4.10.2
描述:
BUGTRAQ  ID: 107799
CVE(CAN) ID: CVE-2019-3880

在samba实现模拟Windows注册服务API的RPC端点的方式中含有一个缺陷。利用此漏洞,无权限的攻击者可以在具有unix权限的任何地方创建新的注册表配置单元文件,这可能导致在Samba共享中创建新文件。

<*来源:Michael Hanselmann
  *>

建议:
临时解决方法:

如果您不能立刻安装补丁或者升级,NSFOCUS建议您采取以下措施以降低威胁:

通过在 smb.conf文件中,
*设置全局参数'min protocol = SMB2',关闭SMB1;或者
*设置全局参数'unix extensions = no',在必须使用SMB1时关闭Unix插件

厂商补丁:

RedHat
------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

https://www.samba.org/samba/history/security.html

浏览次数:1369
严重程度:0(网友投票)
本安全漏洞由绿盟科技翻译整理,版权所有,未经许可,不得转载
绿盟科技给您安全的保障