首页 -> 安全研究

安全研究

安全漏洞
GNU C Library 堆缓冲区溢出漏洞 (CVE-2019-9169)

发布日期:2019-02-26
更新日期:2019-02-27

受影响系统:
GNU C Library (glibc) <= 2.29
描述:
CVE(CAN) ID: CVE-2019-9169

GNU C Library(glibc,libc6)是一种按照LGPL许可协议发布的开源免费的C语言编译程序。

GNU C Library 2.29及之前版本,由于大小写常规表达式匹配问题,posix/regexec.c/proceed_next_node存在堆缓冲区越界读取安全漏洞,可导致信息泄露。

<*来源:vendor
  *>

建议:
厂商补丁:

GNU
---
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

https://debbugs.gnu.org/cgi/bugreport.cgi?bug=34140
https://debbugs.gnu.org/cgi/bugreport.cgi?bug=34142
https://sourceware.org/bugzilla/show_bug.cgi?id=24114
https://sourceware.org/git/gitweb.cgi?p=glibc.git;a=commit;h=583dd860d5b833037175247230a328f0050dbfe9

浏览次数:2038
严重程度:0(网友投票)
本安全漏洞由绿盟科技翻译整理,版权所有,未经许可,不得转载
绿盟科技给您安全的保障