首页 -> 安全研究

安全研究

安全漏洞
Binaryen 堆缓冲区溢出漏洞(CVE-2019-7152)

发布日期:2019-01-29
更新日期:2019-01-30

受影响系统:
Binaryen Binaryen 1.38.22
描述:
CVE(CAN) ID: CVE-2019-7152

Binaryen是一款使用C++编写的、用于WebAssembly的编译器基础结构和工具链库。

Binaryen 1.38.22版本,wasm/wasm-binary.cpp中wasm::WasmBinaryBuilder::processFunctions()函数中存在堆缓冲区越界读取漏洞。攻击者可借助特制的输入,利用该漏洞造成段错误,导致拒绝服务。

<*来源:vendor
  *>

建议:
厂商补丁:

Binaryen
--------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

https://github.com/WebAssembly/binaryen/issues/1880

浏览次数:2584
严重程度:0(网友投票)
本安全漏洞由绿盟科技翻译整理,版权所有,未经许可,不得转载
绿盟科技给您安全的保障