首页 -> 安全研究

安全研究

安全漏洞
GNU C Library 安全漏洞(CVE-2016-10739)

发布日期:2019-01-22
更新日期:2019-01-23

受影响系统:
GNU C Library (glibc) <= 2.28
描述:
CVE(CAN) ID: CVE-2016-10739

GNU C Library是开源免费的C语言编译程序。

GNU C Library2.28及之前版本,getaddrinfo函数在字符串解析中存在安全漏洞,该漏洞源于在解析含有IPv4地址的字符串时,程序会误以为该字符串有效,导致可能会存在嵌入其他危险子串。

<*来源:vendor
  *>

建议:
厂商补丁:

GNU
---
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

https://sourceware.org/git/?p=glibc.git;a=blob_plain;f=NEWS;hb=HEAD

参考:
https://bugzilla.redhat.com/show_bug.cgi?id=1347549
https://sourceware.org/bugzilla/show_bug.cgi?id=20018

浏览次数:2227
严重程度:0(网友投票)
本安全漏洞由绿盟科技翻译整理,版权所有,未经许可,不得转载
绿盟科技给您安全的保障