首页 -> 安全研究

安全研究

安全漏洞
Samba 远程内存破坏安全漏洞(CVE-2018-10858)

发布日期:2018-08-14
更新日期:2018-08-28

受影响系统:
Samba Samba < 4.8.4
Samba Samba < 4.7.9
Samba Samba < 4.6.16
描述:
BUGTRAQ  ID: 105085
CVE(CAN) ID: CVE-2018-10858

Samba是种用来让UNIX系列的操作系统与微软Windows操作系统的SMB/CIFS网络协议做链接的自由软件。

Samba在实现中存在堆缓冲区溢出漏洞,该漏洞源于samba客户端没有充分的检测目录列表中过长的文件名。远程攻击者可借助恶意的samba服务器利用该漏洞在客户端上执行任意代码。

<*来源:Svyatoslav Phirsov
  
  链接:https://www.samba.org/samba/security/CVE-2018-10858.html
*>

建议:
厂商补丁:

Samba
-----
Samba已经为此发布了一个安全公告(CVE-2018-10858)以及相应补丁:
CVE-2018-10858:Insufficient input validation on client directory listing in libsmbclient.
链接:https://www.samba.org/samba/security/CVE-2018-10858.html

参考:
https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10858
https://www.samba.org/samba/security/CVE-2018-10858.html
https://security.netapp.com/advisory/ntap-20180814-0001/

浏览次数:1059
严重程度:0(网友投票)
本安全漏洞由绿盟科技翻译整理,版权所有,未经许可,不得转载
绿盟科技给您安全的保障