首页 -> 安全研究

安全研究

安全漏洞
gv远程缓冲区溢出漏洞

发布日期:2002-09-26
更新日期:2002-09-28

受影响系统:
gv gv 3.5.8
    - RedHat Linux 7.3
描述:
CVE(CAN) ID: CVE-2002-0838

gv是一款PDF和Postscript文件的查看程序,由Johannes Plass维护,可使用在多种Unix操作系统下。

gv不安全的使用sscanf()调用解析PostScript和PDF文件,攻击者可以利用这个漏洞以用户进程权限在系统上执行任意指令。

要利用这个漏洞,攻击者必须发送PDF或者PostScript文件并诱使用户从命令查看文件,由于gv一般不以setuid root属性安装,攻击者只能利用这个漏洞以查看文件进程的权限执行任意指令。由于问题出现发生在用于解析PostScript和PDF文件的sscanf()函数中。

<*来源:David Endler (dendler@idefense.com
  
  链接:http://marc.theaimsgroup.com/?l=bugtraq&m=103305615613319&w=2
*>

建议:
临时解决方法:

如果您不能立刻安装补丁或者升级,NSFOCUS建议您采取以下措施以降低威胁:

* 使用Kghostview工具代替gv来查看PDF或者PostScript文件。

厂商补丁:

gv
--
目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:

http://wwwthep.physik.uni-mainz.de/~plass/gv/

浏览次数:3164
严重程度:0(网友投票)
本安全漏洞由绿盟科技翻译整理,版权所有,未经许可,不得转载
绿盟科技给您安全的保障