首页 -> 安全研究

安全研究

安全漏洞
OpenSSH do_setup_env函数权限提升漏洞(CVE-2015-8325)

发布日期:2016-05-02
更新日期:2016-05-04

受影响系统:
OpenSSH OpenSSH < 7.2p2
描述:
CVE(CAN) ID: CVE-2015-8325

OpenSSH是SSH协议的开源实现。

OpenSSH 7.2p2之前版本, sshd/ session.c/ do_setup_env函数存在安全漏洞, 启用了UseLogin功能且PAM配置为读取用户主目录内的 .pam_environment文件后, 本地用户通过触发/bin/login程序构造的环境, 可提升其权限。

<*来源:OpenSSH
  *>

建议:
厂商补丁:

OpenSSH
-------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

http://www.openssh.com/
https://people.canonical.com/~ubuntu-security/cve/2015/CVE-2015-8325.html
https://people.canonical.com/~ubuntu-security/cve/2015/CVE-2015-8325.html
https://security-tracker.debian.org/tracker/CVE-2015-8325
https://anongit.mindrot.org/openssh.git/commit/?id=85bdcd7c92fe7ff133bbc4e10a65c91810f88755

浏览次数:4911
严重程度:0(网友投票)
本安全漏洞由绿盟科技翻译整理,版权所有,未经许可,不得转载
绿盟科技给您安全的保障