首页 -> 安全研究

安全研究

安全漏洞
OpenSSH <=7.2p1 xauth命令注入漏洞(CVE-2016-3115)

发布日期:2016-03-08
更新日期:2016-03-17

受影响系统:
OpenSSH OpenSSH 〈 7.1p2
描述:
CVE(CAN) ID: CVE-2016-3115

OpenSSH是SSH协议的开源实现。

OpenSSH <=7.2p1在实现上存在xauth命令注入漏洞,可导致绕过forced-command及/bin/false。

<*来源:tintinweb
  *>

建议:
厂商补丁:

OpenSSH
-------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

[1] http://www.openssh.com/
[2] https://github.com/openssh/openssh-portable/blob/5a0fcb77287342e2fc2ba1cee79b6af108973dc2/session.c#L1388
[3] https://github.com/openssh/openssh-portable/blob/19bcf2ea2d17413f2d9730dd2a19575ff86b9b6a/clientloop.c#L376
[4] http://linux.die.net/man/1/xauth
[5] http://www.openssh.com/txt/x11fwd.adv

浏览次数:3700
严重程度:0(网友投票)
本安全漏洞由绿盟科技翻译整理,版权所有,未经许可,不得转载
绿盟科技给您安全的保障