首页 -> 安全研究

安全研究

安全漏洞
RubyGems 'md2pdf'远程命令注入漏洞(CVE-2013-1948)

发布日期:2013-04-15
更新日期:2013-04-16

受影响系统:
rubygems md2pdf
描述:
BUGTRAQ  ID: 59061
CVE(CAN) ID: CVE-2013-1948

md2pdf是将Markdown文档转换为PDF文档的软件。

md2pdf converter.rb中的用户输入,没有经过过滤即传递给命令行,攻击者可利用此漏洞在受影响应用中执行任意命令。

<*来源:Larry W. Cashdollar (lwc@vapid.dhs.org
  
  链接:http://seclists.org/oss-sec/2013/q2/7
*>

建议:
厂商补丁:

rubygems
--------
目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:

https://rubygems.org/gems/md2pdf

浏览次数:4198
严重程度:0(网友投票)
本安全漏洞由绿盟科技翻译整理,版权所有,未经许可,不得转载
绿盟科技给您安全的保障