首页 -> 安全研究

安全研究

安全漏洞
PHP phar_parse_tarfile()整数溢出漏洞

发布日期:2012-07-07
更新日期:2012-07-07

受影响系统:
PHP PHP 5.4.x
描述:
CVE ID: CVE-2012-2386

PHP是一种HTML内嵌式的语言。

PHP phar扩展中tar.c内的函数phar_parse_tarfile()中存在整数溢出漏洞,可允许远程攻击者通过特制的tar文件触发堆缓冲区溢出,造成拒绝服务或执行任意代码。

<*来源:vendor
  *>

建议:
厂商补丁:

PHP
---
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

http://www.php.net

浏览次数:2564
严重程度:0(网友投票)
本安全漏洞由绿盟科技翻译整理,版权所有,未经许可,不得转载
绿盟科技给您安全的保障