首页 -> 安全研究

安全研究

安全漏洞
Linux Kernel agp_allocate_memory/agp_create_user_memory本地权限提升漏洞

发布日期:2011-04-21
更新日期:2011-06-21

受影响系统:
Linux kernel 2.6.x
不受影响系统:
Linux kernel 2.6.38-rc7
描述:
BUGTRAQ  ID: 47535
CVE ID: CVE-2011-1746

Linux Kernel是Linux操作系统的内核。

Linux Kernel在agp_allocate_memory/agp_create_user_memory的实现上存在本地权限提升漏洞,本地攻击者可利用此漏洞以内核权限执行任意代码,造成完全控制受影响计算机。

page_count是从用户空间复制的,agp_allocate_memory()尝试检查此数字是否过大,但是没有考虑溢出的情况。agp_create_user_memory()没有检查alloc_size是否是在没有溢出的情况下从num_agp_pages变量计算出来的。这可能会导致分配过小的缓冲区。

<*来源:Matthiew Herrb
        Vasiliy Kulikov (segoon@openwall.com
  
  链接:https://lkml.org/lkml/2011/4/14/294
*>

建议:
厂商补丁:

Linux
-----
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

http://www.kernel.org/

浏览次数:2044
严重程度:0(网友投票)
本安全漏洞由绿盟科技翻译整理,版权所有,未经许可,不得转载
绿盟科技给您安全的保障